Jump to content
AK47

Head gasket leak

Recommended Posts

I did more dismantling of the front of the Jeep today (nice weather outside). With the front grill and the top metal bar removed, I am able to lift the compressor out of the way. I'm doing this so I don't have to release freon. Next task is ro remove timing chain cover and finally the camshaft.

IMG_20200116_145156757.jpg

Share this post


Link to post
Share on other sites

Thanks @Kapt. Bob. It's indeed a lot of work to get to the camshaft. And I'm only working on it during good weather so it's a bit slow.

I also meant to say condenser instead of compressor. I haven't added R-12 freon since I bought the Jeep in 1994 and it still blows a cool (not cold) air. But is is good enough for now. I wonder how much it would cost for freon to be added.

When I lived in Alaska for 21 years, I never really used the A/C. I just opened my window in the summers.

Share this post


Link to post
Share on other sites

So frustrating to find out that the distributor needs a gasket which I don't have. I have planned for almost everything that I needed for the engine before I left the US two and a half years ago. I am going to wait to pull the crankshaft until after I get the distributor gasket here. I wish there was a Napa or AutoZone nearby. Ah well... maybe I can just run a bead of black RTV sealant. Has anyone done that before?

IMG_20200119_153544099.jpg

IMG_20200119_151032863.jpg

Share this post


Link to post
Share on other sites

RTV is okay to use based on reading a couple of Jeep Cherokee forums. So I guess I'll keep on going. 👍

Share this post


Link to post
Share on other sites

There are some good suppliers for Jeep parts around in the Netherlands. They ship the same day, so it will be in your place the next day if your lucky.....

Jeep parts.nl

4offroad

4Low

B&S autoparts

They all have a online webshop, just give a call when your part is not available there. Most off the time it's available within a few days.

 

Share this post


Link to post
Share on other sites

Thanks for the tip, @Ab! I'll check them out if I'm in a bind.

So, I removed the distributor and cleaned it. Will replace using black RTV.

I also installed the new camshaft with lots of Clevite cam lube. I cleaned the tappet bores with an old brass shotgun barrel brush that I had lying around.

It helped a lot with the camshaft installation when I attached the sprocket and used it as a handle. I am still going to be very mindful that there is a small nick on the front bearing that I saw when I removed the original camshaft. However, it slid in nicely. So I may have to do a teardown in the next couple of years.

IMG_20200120_143012836.jpg

IMG_20200120_131523330.jpg

Share this post


Link to post
Share on other sites

I wish I measured the lobe lifts before I removed the old one.

Share this post


Link to post
Share on other sites
Op 19/1/2020 om 5:16 PM zei AK47:

 

IMG_20200119_151032863.jpg

Hi, Did you also check if the chain is within specs? Seems very loose on the photo.

Share this post


Link to post
Share on other sites
7 hours ago, Arjanw said:

Hi, Did you also check if the chain is within specs? Seems very loose on the photo.

I honestly don't remember how tight it was when I installed it. And now that you mentioned it @Arjanw I will have to verify. My logbook will tell me when I changed it but it may have been about 100,000 miles (160,000 km) ago. In that case, it might be due for a change. The tensioner spring was extended but not to its fullest so I may have some more miles to go, and I haven't heard any chain slap (yet) 🙄.

Today, I just cleaned old gasket from the timing chain cover and aligned the TDC on the sprockets and harmonic balancer. I pulled the distributor out to double-check where the rotor was pointing. I think I will reinstall the distributor tomorrow. The FSM calls for the oil pump screw to be in a specific orientation with respect to the block. I may have gotten it wrong yesterday. Oh well, I'll have to read up again on it.

Yep, I will soak the lifters in oil @REAL STRANGLER. I bought a 5L jug of dinosaur oil 10W50. I read that it's best to do this before going back to Mobil1 synthetic oil I normally use. At least for the first 500 miles (800 km). I looked in my spare supplies and I have 2 oil filters so I'm good. Will have to buy new ones locally after that.

Screenshot_20200121-190804.png

IMG_20200121_133433487.jpg

Share this post


Link to post
Share on other sites

Hmmm. I just checked my logbook and it shows I changed my timing chain, the tensioner, the oil seal, and the cover on 01 Nov 2015. It seems too soon to change it again. I'll keep an eye on it. The tensioner spring looks halfway deployed so it should last another five years. We'll see.

Share this post


Link to post
Share on other sites

So the head is now back on the block. What a PITA to lift that thing over the engine bay and then line it up to the guide pins. New head bolts installed and torqued to spec.

IMG_20200123_132529528.jpg

IMG_20200123_130722638.jpg

Share this post


Link to post
Share on other sites

One of my rocker arms was slightly twisted so I used a locking vise grip to hold it and twist. I saw this in a video and it worked. I also bolted the exhaust and intake manifolds. So far assembly is the reverse of disassembly. Getting there. This weekend I will flush the coolant lines to and from the block to clean it before putting the thermostat back in. Will flush the radiator, too.

IMG_20200124_134347209.jpg

Share this post


Link to post
Share on other sites

I would replace that metal pipe coming from the waterpump as well. Those are famous to rust from inside, and that rust will get everywhere in the cooling system.

You won't put a new thermostat and radiator now you have everything open?

Share this post


Link to post
Share on other sites
26 minutes ago, Masis said:

I would replace that metal pipe coming from the waterpump as well. Those are famous to rust from inside, and that rust will get everywhere in the cooling system.

You won't put a new thermostat and radiator now you have everything open?

Good tip @Masis. I might do that the next time I change my water pump. I just changed it last July so it may be a while. I hope the rust inhibitor in the coolant can keep it clean until then. I also changed my thermostat last July so I'm reusing it for now. I used to have the higher temp one (195F) since I lived in Alaska, but I now have the 190F thermostat. As for the radiator, I am going to replace it soon. I think it's my next purchase. I have to stagger my purchases so my wife doesn't get too suspicious; she already thinks I'm spending more on the Jeep than on her (and she might be right 🤫).

 

Share this post


Link to post
Share on other sites

I checked my logbook again and it looks like I was using a 205F thermostat in Alaska and now I'm back to 195F.

Today I flushed the coolant/heater core lines, reinstalled the A/C, power steering, fan, fan belt, radiator, A/C condenser, hoses, and the front metal brackets.

I have to get coolant so I can start the thing. But I also have to repair the stripped oil pan drain before I put oil in tomorrow.

I hope this thing runs. My neighbor has a stroboscope that he can lend me to check the timing (I'm still not sure if I set the distributor right).

IMG_20200126_163433837.jpg

Share this post


Link to post
Share on other sites
Op 24/1/2020 om 7:43 PM zei AK47:

I have to stagger my purchases so my wife doesn't get too suspicious; she already thinks I'm spending more on the Jeep than on her (and she might be right 🤫).

Hahahaha, so recognizable...

  • Like 1

Share this post


Link to post
Share on other sites

Tapped a new drain hole (13mm) for the oil pan. It was too stripped. Now I can add oil and start the xj for the first time with the new cam. Just waiting for the rain to stop.

IMG_20200129_101045962.jpg

Share this post


Link to post
Share on other sites

A litlle tip, you'll already know perhaps, leak a small amount of oil out the drain hole first to get metal parts out the carter before you replace your stop..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...